MailerCheck

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Service Disruption
Resolved·Degraded performance

This incident has been resolved.

Thu, Jun 12, 2025, 08:30 PM
(10 months ago)
·
Affected components
Jun 12, 2025, 07:47 PM
08:30 PM
Website
MailerCheck APP
MailerCheck API
Email validation
Inbox insights
Updates

Resolved

This incident has been resolved.

Thu, Jun 12, 2025, 08:30 PM

Investigating

We are currently experiencing a service disruption due to a global outage affecting Google Cloud Platform (GCP), which is one of our core infrastructure providers.

The Google Cloud outage is causing some instability across our app, including degraded performance and partial service outages.This is an external infrastructure issue, but it is directly impacting our ability to serve requests reliably.

The incident is global and being actively investigated by Google. You can follow their updates here: https://status.cloud.google.com/

Thu, Jun 12, 2025, 07:47 PM(43 minutes earlier)